Zikula requires PHP version 5.3.2 or greater. Your server is using version 5.2.17.